Bijwerken niet nodig wordpress database is al up to date

By 22 augustus 2017 januari 7th, 2019 Wordpress

Heb jij met WordPress na een update of upgrade ook deze foutmelding: “Bijwerken niet nodig – je wordpress database is al up to date”. Dat gaan wij oplossen.

Voor velen ziet de URL er als volgt uit: wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F
Wat gaat er eigenlijk fout? Door een oude cache denkt wordpress dat de versie’s niet overeenkomen. Hierdoor worden scripts aangestuurd om de database te updaten. Maar na een echte check blijkt het helemaal niet nodig te zijn en krijg je deze foutmelding “Bijwerken niet nodig wordpress database is al up to date“.

Cache bestand hernoemen

De eenvoudigste stap om dit probleem op te lossen is door het bestand object-cache.php te hernoemen. Mijn voorkeur gaat uit naar de tweede oplossing, maar deze is net iets makkelijker. Tijd om het probleem op te lossen. Ga naar de bestandslocatie waar WordPress staat. Misschien heb je hiervoor FTP nodig.

  1. Ga naar de folder wp-content
  2. Hernoem object-cache.php naar object-cache.old

Probeer het nu nog eens. Als het goed is moet het nu wel goed werken. Werkt het niet? Probeer dan eens de volgende stap.

Cache legen / flushen

Wij gaan WordPress opdracht geven de cache te legen. Het is daarbij niet eens nodig het bestand object-cache.php te verwijderen. Heb je dit wel gedaan, dan is dat geen probleem. Deze oplossingen staan los van elkaar. Dan nu oplossing:

Maak een flush.php bestand (dit kun je eenvoudig doen met notepad) en plaats daar de volgende code in:

flush.php
1

2

3

4

<?php

include( ‘./wp-load.php’ );

wp_cache_flush();

?>

 

  1. Upload flush.php naar de hoofdmap / root van WordPress
  2. Ga naar je website toe en verander de url in www.jouwwebsite.nl/flush.php
  3.  Je zult een lege pagina zien, en dat is goed.
  4. Verwijder flush.php weer uit de hoofdmap / root van WordPress
  5. Probeer weer in te loggen en zie het resultaat
× Waarmee kan ik u helpen?